CGPersia Forums
Release Blog CGPeers IRC Chat FAQ
Go Back   CGPersia Forums > Other OSes > Linux - Requests
Reload this Page Background Reactor Flame 2018 up - LNX64 only
Linux - Requests Linux Software Requests

Reply
 
Thread Tools Search this Thread
Old 10-09-2017, 05:48:12 PM   #1
Original Poster
Join Date: Jan 2011
Posts: 4
Thanks (Given): 6
Thanks (Received): 1
Default Background Reactor Flame 2018 up - LNX64 only

Is anyone got Background reactor render working with Flame 2018, or 2018.1 or 2018.2 lic solution by o0o0o0o0o?

I have 2018 and 2018.2 running, i added second graphic card and nothing is happening.
Tried format and re-install the whole CentOS, made Flame work by o0o0o0o0o and again also no Background reactor.

Anyone got it? Or actually need a special second license/crack solution?

Many Thanks
is Offline  
Reply With Quote
Old 10-09-2017, 11:25:36 PM   #2
uirado
Join Date: Aug 2013
Posts: 45
Thanks (Given): 16
Thanks (Received): 8
No additional license needed for 2018.

You need to specify in xorg.conf which is the board that will be used by the reactor: look for dual gpu

and run /usr/discreet/backburner/backburnerConfig to reconfigure your backburner to found the board
is Online  
Reply With Quote
Old 10-10-2017, 04:16:05 PM   #3
darkmarketing
Join Date: Jan 2012
Posts: 203
Thanks (Given): 48
Thanks (Received): 330
@trackerweb what is your dual gpu setup? Remember that it must be dual identical gpu cards, dual titan, dual k6000, dual gtx 1080,etc.
is Offline  
Reply With Quote
Old 10-10-2017, 08:54:09 PM   #4
mitoun
Join Date: Mar 2011
Posts: 2
Thanks (Given): 1
Thanks (Received): 0
@trackerweb .. i didn't have success too .

Even I am using 2 quadro 6000 , i didn't get a reactor working .
maybe a trouble in the setups as Uirado have said.

but to me it worked perfectly with FL 2015.

At least, with the FL2018 from o0o0o0o0o, i can burn with backburner too the renders on an another computer. It works .
is Offline  
Reply With Quote
Old 10-10-2017, 10:54:24 PM   #5
uirado
Join Date: Aug 2013
Posts: 45
Thanks (Given): 16
Thanks (Received): 8
Link(s):
 
1 - open terminal and run nvidia-smi

the result will be something like this:


+------------------------------------------------------+
| NVIDIA-SMI 346.35 Driver Version: 346.35 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+================= =====+======================|
| 0 Quadro 6000 Off | 0000:03:00.0 On | 0 |
| 38% 86C P0 N/A / N/A | 4971MiB / 5375MiB | 0% Default |
+-------------------------------+----------------------+----------------------+
| 1 Quadro 6000 Off | 0000:82:00.0 Off | 0 |
| 45% 87C P0 N/A / N/A | 2319MiB / 5375MiB | 0% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|================================================= ============================|
| 0 12224 C ...flame_2017.0.3/bin/flame_LINUX_2.6_x86_64 4704MiB |
| 1 19762 C ....3/bin/backgroundreactor_LINUX_2.6_x86_64 2244MiB |
+-----------------------------------------------------------------------------+


2 - converto PCIID (BusID) information from hex to decimal:

ex.:

Graphic 1 - seted as on, used by flame: hex 03:00.0 > decimal 03:00.0

Graphic 2 - seted as off, used by reactor: hex 82:00.0 > decimal 130:00.0




3 - open /etc/X11/xorg.conf and look for Section "ServerLayout" and uncomment last line "dual gpu"

Screen 1 "Screen Dummy Dual GPU Screen" Relative "Screen nVidia FX1700/FX1800/FX3700/FX3800/4000 1280x1024" 0 0

----------------------------------------------------------------
Section "ServerLayout"
# Screen 0 "Screen EIZO CG318 6000 4096x2160" 0 0
# Screen 0 "Screen EIZO CG277 6000 2560x1440" 0 0
# Screen 0 "Screen Lustre / EIZO CE24xW 6000 SDI 1920x1200" 0 0
# Screen 0 "Screen EIZO CG24xW K6000 SDI 1920x1200" 0 0
# Screen 0 "Screen Lustre / EIZO CE24xW FX5800 SDI 1920x1200" 0 0
# Screen 0 "Screen Lustre / EIZO CE24xW FX5600 SDI 1920x1200" 0 0
Screen 0 "Screen nVidia FX1700/FX1800/FX3700/FX3800/4000 1280x1024" 0 0
# Screen 0 "Screen Default 1920x1200 EDID" 0 0
# Screen 0 "Screen Default 1920x1200 NO-EDID" 0 0
# Screen 0 "Screen Default 2560x1440 EDID" 0 0
# Screen 0 "Screen Default 2560x1440 NO-EDID" 0 0
# Screen 0 "Screen Default 1920x1080 EDID" 0 0
# Screen 0 "Screen Default 3440x1440 EDID" 0 0
# Screen 0 "Screen Default 3840x2160 EDID" 0 0
# Screen 0 "Screen Default 4096x2160 EDID" 0 0
Screen 1 "Screen Dummy Dual GPU Screen" Relative "Screen nVidia FX1700/FX1800/FX3700/FX3800/4000 1280x1024" 0 0
--------------------------------------------------------


4 - still on xorg and look for 'Section "Device" Identifier "NVIDIA Quadro Generic NO-EDID"

uncomment last line and add the BusID value from up graphic card informed on nvidia-smi, in my case "BusID" "PCI:03:00:0":

Option "BusID" "PCI:03:00:0"


------------------------------------------------------------
Section "Device"
Identifier "NVIDIA Quadro Generic NO-EDID"
Driver "nvidia"
BoardName "Unknown"
Option "Overlay" "on"
Option "Interactive" "False"
Option "ModeValidation" "NoEdidMaxPClkCheck, NoHorizSyncCheck, NoVertRefreshCheck"
Option "ExactModeTimingsDVI" "True"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222"
# Option "TwinView" "true"
# Option "UseDisplayDevice" "DFP-X"
# Option "IncludeImplicitMetaModes" "False"
# Option "nvidiaXineramaInfoOrder" "DFP-X"
# Option "MetaModes" "DFP-X: X1RESxY1RES +X1OFFSET+0, DFP-Y: X2RESxY2RES +X2OFFSET+0"
Option "BusID" "PCI:03:00:0"
EndSection
-------------------------------------------------------------------------------


5 - still on xorg and look for 'Section "Device" Identifier "Dual GPU"

look for BusID ans addthe value from the second graphic card informed on nvidia-smi, in my case 'BusId "PCI:130:0:0"'


-----------------------------------------
Section "Device"
Identifier "Dual GPU"
Driver "nvidia"
BoardName "Unknown"
BusId "PCI:130:0:0"
Option "UseDisplayDevice" "none"
Option "Interactive" "False"
EndSection
-------------------------------------------



6 - save and close xorg.conf


7 - open terminal as su and run:
/usr/discreet/backburner/backburnerConfig

yes
yes
localhost

8 - reboot your machine

Reactor is running...
is Online  
Reply With Quote
2 Thanks, 0 Dislike - trackerweb, mitoun thanked for this post